Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n. если можно побыстрее, а то на завтра нужно.

Зуев693 Зуев693    1   22.07.2019 10:20    1

Ответы
тамик50 тамик50  03.10.2020 10:32
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln('s=',Range(ReadInteger('n='),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write('n='); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln('s=',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика