Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)

Atax1a1 Atax1a1    2   19.08.2019 07:40    2

Ответы
you58 you58  05.10.2020 04:24
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('ем',''); s.Println
end.

Пример
> земля- планета солнечной системы
зля- планета солнечной систы
ПОКАЗАТЬ ОТВЕТЫ
Андріана1111111 Андріана1111111  05.10.2020 04:24
// PascalABC.NET (версия 3.2, сборка 1363)

const
  RM = 'ем';
var
  c, n: char;
  seq: boolean := False;
  s: string := 'Земля - планета солнечной системы';
begin
  writeln(s);
  for var i := 1 to (length(s) -1) do
  begin
    c := s[i];
    n := s[i+1];
    if seq = True then
    begin
      seq := False;
      continue;
    end;
    if (c = RM[1]) and (n = RM[2]) then
    begin
      seq := True;
      continue;
    end
    else
    begin
      seq := False;
      write(c);
    end;
  end;
  write(s[length(s)]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика