Напишите программу, которая сортирует массив в порядке убывания. 7. Напишите программу, которая сортирует массив по возрас- танию последней цифры числа. C++

rtrc2002 rtrc2002    1   21.04.2020 06:50    4

Ответы
shevchal shevchal  13.10.2020 13:32

Массив по убыванию:

#include<stdio.h>

#include<conio.h>

 

int numb[11];

int i,a,n;

 

int main()

{  

   //clrscr();

   for(i=0;i<=10;i++)

   {  

       numb[i]=i;

       printf (" %d",numb[i]);

   }

   n=1;

   while(n)

   {

           n=0;

           for(i=0;i<10;i++)

           {  

             if (numb[i]<numb[i+1])

             {  

                n=1;

                a=numb[i+1];numb[i+1]=numb[i];

                numb[i]=a;

             }

           }

   }

   for(i=0;i<=10;i++)  

       printf(" %d ",numb[i]);

   getch();

   return 0;

}

Сортировка массива по последней цифре:

#include <bits/stdc++.h>

 

   using namespace std;

   

bool f(const int rhs, const int lhs)

{

return (rhs % 10 < lhs % 10);

}

 

int main() {

   int n;

   cin >> n;

   int* arr = new int[n];

   for (int i = 0; i < n; i++) {

       cin >> arr[i];

   }

   sort(arr, arr + n, f);

   for (int i = 0; i < n; i++) {

       cout << arr[i] << " ";

   }

   delete [] arr;

   system("pause");

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика