Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). размер массива заранее неизвестен. исходные данные записаны в файл input.txt , отсортированный массив нужно вывести в файл output.txt . входные данные все элементы массива записаны по одному в каждой строке входного файла input.txt . ввод завершается числом 0. выходные данные программа должна вывести в файл output.txt все элементы отсортированного массива в одной строке, разделив их пробелами. примеры входные данные 5 1 -4 -2 3 0 выходные данные -4 -2 1 3 5

shidiemmacom1 shidiemmacom1    3   24.08.2019 09:10    8

Ответы
Chinchil1a Chinchil1a  09.08.2020 18:44
Program n1;
type z = array of integer;
var a: z;
i,n,j,buf,t: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
n:=1;
t:=0;
while true do
begin
readln(f,t);
if(t<>0) then
begin
setlength(a,n);
a[n-1]:=t;
end else break;
n:=n+1;
end;
close(f);
for i:=0 to n-3 do
for j:=i+1 to n-2 do
if a[i]>a[j] then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
end;
assign(f,'output.txt');
rewrite(f);
for i:=0 to n-2 do write(f,a[i],' ');
close(f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика