Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.


Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ров

Вичка03 Вичка03    1   17.12.2020 10:30    16

Ответы
solnyshko46 solnyshko46  16.01.2021 10:30

Код:

list_of_words = {}

searched_num = 0

arr_count = int(input("Введите количество элементов: "))

if arr_count < 0 or arr_count > 1000:

   exit(print("\nНеверное количество элементов!"))

arr = sorted(input("\nВведите массив через пробел: ").split())

oftn_num = int(input("\nВведите число: "))

if arr_count != len(arr):

   exit(print("\nКоличество элементов не совпадает!"))

for i in arr:

   if i in list_of_words:

       list_of_words[i] += 1

       continue

   list_of_words[i] = 1

for key, val in list_of_words.items():

   if val == oftn_num:

       print(key, end=' ')

       searched_num += 1

if not searched_num:

   print(0)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика