Дано натуральное число n. Составить программу вычисления значения. Результат округлить до сотых.
В Паскале, через оператор повторения.

linakkj linakkj    3   26.03.2020 23:17    1

Ответы
KrASaVa307 KrASaVa307  12.10.2020 06:29

var n,i,j: integer;

var res,sum: double;

begin

writeln('Введите n');

readln(n);

i:=1;

j:=1;

res:=0;

while (i<=n) do

 begin

 sum:=0;

 j:=1;

 while (j<=i) do

   begin

   sum:=sum+sin(j);

   j:=j+1;

   end;

 res:=res+(1/sum);

 i:=i+1;

 end;

writeln('ответ: ',res:5:2);

end.

 

   

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика