tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу, которая считает
Напишите программу, которая считает три числа и большее из них уменьшит на 5.
fkdsf234
2 16.06.2019 12:00
2
Ответы
alekseymedvedev
13.07.2020 08:55
Program gt;
var a,b,c,max:integer;
begin
readln(a,b,c);
max:=a;
if(b>max)then max:=b;
if(c>max)then max:=c;
if(a=max)then a:=a-5;
if(b=max)then b:=b-5;
if(c=max)then c:=c-5;
writeln(a,' ',b,' ',c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
karina211206
21.04.2020 20:04
Напишите программу на языке Паскаль. Даны два целых числа a и b, если а больше b, то из a вычесть b. Если b больше а, то к b прибавить 10. Если числа равны, то посчитать...
axeltrofimsky
21.04.2020 20:05
Рассчитайте объем видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 160х256 и палитрой из 32 цветов....
angelinashushi
21.04.2020 20:49
Дана последовательность операторов a:=1 b:=1 repeat a:=a+1; b:=b*2; until b 8; s:=a+b Чему будут равны a,b,s после исполнения этой последовательности операторов?...
Давидка12
21.04.2020 20:49
Дано число х увеличьте его на 20 если оно не отрицательно, во всех остальных случаях уменьшить на по братски...
sasunaklukina
21.04.2020 20:49
1. Напишите наименьшее целое число x, для которого истинно высказывание: НЕ (X 9) И НЕ (X нечётное). 2. Напишите наибольшее целое число x, для которого истинно высказывание:...
lionkeepo
21.04.2020 20:49
К какому типу относится модем в лаборатории, а к какому ваш домашний?...
SweetDreamsOfMade
21.04.2020 20:49
Записать в однобайтовом формате прямой код числа 103...
79042532294
21.04.2020 20:50
Какой из перечисленных типов данных предназначен для описания целочисленныхзначений?...
Desergei93
21.04.2020 20:50
Сколько раз выполняется тело цикла для каждого фрагмента программы?...
bogdan39
21.04.2020 20:50
ответить Создать пары добавив с английским термином русский аналаг CPU- RAM- HDD- Video Card- Sound Card-...
Популярные вопросы
ИНФОРМАТИКА 10 КЛАСС ЦИКЛ С ПРЕДУСЛОВИЕМ...
2
Сократить дробь по алгебре сор 7 класс...
1
Сообщение на тему: Речевой этикет (учимся благодарить)...
2
Перед вами цепочка септаккордов, построенных в тональности Си...
2
Помагите сор 1 за 4 четверти 5 класс ...
1
с заданием.5 класс Английский язык....
3
Каз.яз. Нужно составить диалог нужно....
1
Яке хобі було в діда Яви з твору Всеволода Нестайка Тореадори...
3
Спишите предложения расставьте знаки препинания объясните их...
2
На яку висоту піднімется кулька масою 5 г, випущена з дитячого...
3
var a,b,c,max:integer;
begin
readln(a,b,c);
max:=a;
if(b>max)then max:=b;
if(c>max)then max:=c;
if(a=max)then a:=a-5;
if(b=max)then b:=b-5;
if(c=max)then c:=c-5;
writeln(a,' ',b,' ',c);
end.