Напишите программу, которая проверяет, можно ли получить из одного имени другое путем перестановки его букв. при этом регистром букв нужно пренебречь. stop pots yes abbc bac no написать на paskal

antoncezame antoncezame    3   18.09.2019 02:20    2

Ответы
samuskevich samuskevich  07.10.2020 23:05
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  // вводим строку, перекодируем к нижнему регистру и делим на два слова
  var a:=ReadlnString.ToLower.ToWords;
  var (n1,n2):=(a[0].Length,a[1].Length); // длины слов
  if n1<>n2 then begin Writeln('No'); exit end;
  for var i:=1 to n1 do begin
    var p:=Pos(a[0][i],a[1]);
    if p=0 then begin Writeln('No'); exit end;
    Delete(a[1],p,1)
    end;
  Writeln('Yes')  
end.

Примеры
stop pots
Yes

aBbC bAc
No

ПароВоз ЗовоПар
Yes
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика