tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу, которая
Напишите программу, которая производит обмен згачений переменных x и y, если x больше y. пример входных пример выходных данных данных x> > 5 x=6 y> > 6. y=5 x> > 6 x=5 y> > 5. y=6
ybrfyjh
3 24.07.2019 16:40
3
Ответы
ladyled
31.07.2020 18:48
Решение №1
var x,y:integer;
begin
readln(x,y);
if x> y then begin
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y);
end.
Тестовое решение:
8 5
5 8
Решение №2
На PascalABC.Net можно сделать проще:
var x,y:integer;
begin
readln(x,y);
if x>y then begin swap(x,y); println(x,y); end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
marinet2017
28.08.2019 04:50
Разработать алгоритм и составить программу вычисления значений по формулам: p=(a+)^2+a cos(a+b)+акореньb/a+b, где a=x+y, b=x^2+y^2...
DashaBudlevskaya
16.05.2020 17:03
Вводятся три числа, найти количество трёхзначных положительных чисел, кратных...
TigerForceCasual
16.05.2020 17:04
Постройте блок-схему выбора для героев мультфильма с условиями по указательному камню в мультфильме Алёша Попович и Тугарин змей...
zenalubimova
16.05.2020 17:04
Напишите программу, которая в последовательности натуральных чисел определяет сумму всехчисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные числа, количествовведённых...
Школьниқ
16.05.2020 17:04
Нужно решитьтести по информатека 1. Інноваційна форма організації освітнього середовища, в основі якої - комплексний характер діяльності тимчасового колективу спеціалістів в умовах...
Littlebybigheart1111
16.05.2020 17:04
Написать программу для нахождения суммы чёрных элементов массива не оканчивающихся на ноль. ИНФОРМАТИКИ МНОГО...
крыска235
16.05.2020 17:04
Дан массив из 12 случайных чисел в диапазоне от 1 до 200. Найти количество двузначных чисел...
Sk174
17.07.2019 01:30
Роль и назначение операционной системы microsoftwindows (сравнительный анализ возможностей различных версий семейства операционных систем microsoftwindows)....
vladysh205
17.07.2019 01:30
Декодируй указанное сообщение с шифра цезаря: фхгуюм жуцё оцъыз рсеюш жецш каждая буква исходного текста заменяется третьей после неё буквой в алфавите языка, который считается записанным...
И1111111111111111
10.08.2020 18:18
подтвердить аккаунт в WeChat Кто-нибудь у кого есть WeChat, укажите мой моб. номер для подтверждения. Буду очень благодарен...
Популярные вопросы
Городов расстояние между которыми 1380 км вышли одновременно навстречу друг другу...
2
Составьте уравнение реакции водорода с оксидом вольфрама не списывать с других...
2
Решите уравнение (подробно) 4/9y+1/3y=6,3 , 24...
2
Вклассе 20 учеников,14 из них девочки,а остальные мальчики.сколько мальчиков в...
2
Виды перерабатывающего топлива тениз...
3
Решить ! (2/15+7/12)*30/43-2: 2 1/2 *5/32...
3
Найдите значение выражения (3√5)^2/15...
1
Охарактеризовать период 1930 - 1940 внешняя и внутренняя политика...
1
Проверочное слово слова другие друг друг...
2
Вмагазине продали 2 коробкиигрушек.в первой коробке 32 игрушки,а во второй коробке...
1
var x,y:integer;
begin
readln(x,y);
if x> y then begin
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y);
end.
Тестовое решение:
8 5
5 8
Решение №2
На PascalABC.Net можно сделать проще:
var x,y:integer;
begin
readln(x,y);
if x>y then begin swap(x,y); println(x,y); end;
end.