Написать программу для нахождения суммы чёрных элементов массива не оканчивающихся на ноль. ИНФОРМАТИКИ МНОГО

Littlebybigheart1111 Littlebybigheart1111    2   16.05.2020 17:04    1

Ответы
Евгения200605 Евгения200605  14.10.2020 20:49

const Sz = 10000;

var

 a: array [1..Sz] of integer;

 N: integer;

 i: integer;

 sum: integer;

begin

 sum := 0;

 write('Введите количество элементов в массиве: ');

 readln(N);

 write('Введите элементы массива: ');

 for i:=1 to N do

 begin

   read(a[i]);

   if (a[i] mod 2 = 0) then

   begin

       if (a[i] mod 10 <> 0) then

       begin

           sum := sum + a[i];

       end;

   end;

 end;

   

 write('Сумма элементов: ', sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика