Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере: Случайное число 83

В восьмеричной системе 123
Язык python

DENZYSUPER DENZYSUPER    3   19.10.2020 09:41    69

Ответы
mexoc mexoc  18.11.2020 09:41

import random

def to8(x):

       new=''

       while x>0:

           new=str(x%8)+new

           x //= 8

       return(new)

a=random.randint(64,511)

print('Случайное число',a)

print('В восьмеричной системе',to8(a))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика