Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три цифры номер выход: первая строка представляет собой сумму цифр(в python)

ksarbinaz ksarbinaz    3   28.04.2020 15:38    4

Ответы
VikiMikiSmile VikiMikiSmile  18.08.2020 09:59

n=int(input("Число: "))

sum = 0

while n>0:

   sum += n%10

   n=int(n/10)

   

print(sum)

Объяснение:


Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три ци
ПОКАЗАТЬ ОТВЕТЫ
VladeslavPavlo VladeslavPavlo  18.08.2020 09:59

python не знаю, но подскажу.

Объяснение:

тебе нужно найти остаток от деления на 10, потом остаток прибавить к сумме. После, входное число нацело разделить на 10. Оставшейся число пропускаем через эти шаги до того момента, пока оно не будет равняться 0

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика