напишите программу, которая переставляет элементы массива в обратном порядке без использования дополнительного массива. программа должна считать массив, поменять порядок его элементов, затем вывести результат (просто вывести элементы массива в обратном порядке – недостаточно! )

входные данные
сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел.

выходные данные
необходимо вывести массив, полученный после перестановки элементов.

примеры

входные данные

6

4 5 3 4 2 3

выходные данные

3 2 4 3 5 4

нужно в паскале!

50

тса2 тса2    1   06.12.2019 17:46    25

Ответы
СергеЙ89009021645 СергеЙ89009021645  10.10.2020 18:57

Получилось довольно криво, но вот

var a : array [1..255] of integer;

n, i: integer;

BEGIN

read(n);

for i := 1 to n do

 read(a[i]);

for i := 1 to trunc(n / 2) do begin

 a[i] += a[n - i + 1];

 a[n - i + 1] := a[i] - a[n - i + 1];

 a[i] -= a[n - i + 1];

end;

for i := 1 to n do

 write(a[i], ' ');

END.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика