Напишите программу которая определяет nod трех натуральных чисел (с использованием процедур)

dylanboy dylanboy    2   02.06.2019 12:20    2

Ответы
meshiydima meshiydima  03.07.2020 08:46
Var
 a,b,c:integer;
procedure main(a,b,c:integer);
var
 i,max,nod:integer;
begin
 if (a>b) and (a>c) then
  max:=a
 else
  if (b>a) and (b>c) then
   max:=b
  else
   max:=c;
 nod:=1;
 for i:=1 to max do
 begin
  if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
   nod:=i;
 end;
 writeln(nod);
end;
begin
 read(a,b,c);
 main(a,b,c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика