Напишите программу,которая находит минимальный и максимальный элементы матрицы и их индексы
Python

olchik75 olchik75    3   22.04.2020 15:57    27

Ответы
Тппсхп Тппсхп  28.08.2020 11:48

min = 1

for i in range(0, len(matrix) ) :

for k in range(0,len(matrix[i])) :

 b = matrix[i][k]

 if b < min :

  ind =[i,k]

  min=b

max = 1

for i in range(0, len(matrix) ) :

for k in range(0,len(matrix[i])) :

 b2 = matrix[i][k]

 if b2 > max :

  ind2 =[i,k]

  max=b2

Объяснение:

min и max - временные переменные , используемые в цикле  

min - минимальное значение матрицы max - максимальное значение

matrix - собственно сама матрица

ind - массив хранящий индекс матрицы с минимальный значением

ind2 - массив хранящий индекс матрицы с максимальным значением

ПОКАЗАТЬ ОТВЕТЫ
рана7 рана7  28.08.2020 11:48

lst = [[int(_) for _ in input().split()] for p in range(int(input()))]

mx_ind, mn_ind, mn, mx = (0, 0), (0, 0), max(max(lst)), 0

for i in range(len(lst)):

   for j in range(len(lst[i])):

       if lst[i][j] < mn:

           mn = lst[i][j]

           mn_ind = (i, j)

       if lst[i][j] > mx:

           mx = lst[i][j]

           mx_ind = (i, j)

print(f'Наибольший: A[{mx_ind[0]}][{mx_ind[1]}] = {mx}')

print(f'Наименьший: A[{mn_ind[0]}][{mn_ind[1]}] = {mn}')

На первой строчке вводишь количество строк в матрице(1 число)

На следующих n строчках вводишь матрицу

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика