Напишите программу,которая для заданной последовательности натуральных чисел подсчитывает сумму входящих в неё трехзначных чисел,которые делятся на 7.программа получает на вход кол-во чисел в прследовательности, а затем сами числа.кол-во чисел не превышает 1000.введенные числа не превышают 30 000.программа должна вести одно число-сумму трехзначных чисел,находящихся в заданной последовательности натуральных чисел.

Настя25112005 Настя25112005    2   01.09.2019 21:00    5

Ответы
zD3VOLYx zD3VOLYx  06.10.2020 10:27
Program hhh54;
var n,x,i,s: longint;
begin
  s:=0;
  read (n);
  for i:=1 to n do;
    begin
      read (x);
      if (x > 99) and (x < 1000) and (x mod 7 = 0) then s:=s+x;
    end;
  write (s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика