Напишите программу, которая будет проверять какое сейчас время года. Она будет спрашивать у пользователя номер месяца (от 1 – Январь до 12 – декабрь), а затем выводить сообщение в консоль о том, какое это время года.

Например, если номер месяца 5 (май), то программа выведет сообщение “Сейчас весна”.

У нас уже есть проверка на правильность ввода, если пользователь введет число меньше 1 или больше 12, то программа выводит сообщение об ошибке, ведь такого месяца не существует.

Тётко Тётко    3   08.11.2021 07:05    7

Ответы
Supermopsmeni Supermopsmeni  08.11.2021 07:10

Программа:

Python:

def month(m):

   if m == 1 or m == 2 or m == 12:

       print('Сейчас зима')

   elif m == 3 or m == 4 or m == 5:

       print('Сейчас весна')

   elif m == 6 or m == 7 or m == 8:

       print('Сейчас лето')

   elif m == 9 or m == 10 or m == 1:

       print('Сейчас осень')

   else:

       print('Такого месяца не существует')

if __name__ == '__main__':

   m = int(input())

   month(m)

ПОКАЗАТЬ ОТВЕТЫ
valeria204567 valeria204567  08.11.2021 07:10

N = int(input())

if N < 1 or N > 12:

   print('Ошибка')

else:

   if N in [1, 2, 12]:

       season = 'зима'

   elif N in [3, 4, 5]:

       season = 'весна'

   elif N in [6, 7, 8]:

       season = 'лето'

   elif N in [9, 10, 11]:

       season = 'осень'

   print('Сейчас ' + season)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика