Напишите программу для решения следующей в qbasic девятиклассники участвовали в викторине по . необходимо было ответить на 20 вопросов. победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. на сколько вопросов победитель ответил правильно? если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите yes, иначе выведите no. гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов. программа получает на вход число участников викторины n (1 ≤ n ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. пример работы программы: входные данные 4 15 12 0 17 выходные данные 17 yes

KalipsoMirai KalipsoMirai    2   24.06.2019 10:40    3

Ответы
mixrasp2002 mixrasp2002  19.07.2020 22:58
var
    i, k,n, max: integer;
    f:boolean;
begin
    readln(k);
    for i := 1 to k do
    begin
        readln(n);
        if (i = 1) or (max < n) then
            max := n;
        f:=f or (n=0);
    end;
    writeln(max,' ', f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика