tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите, , программу
Напишите, , программу . дано: х, у, z найти: вывести на экран только положительные числа и найти сумму отрицательных
4433225566
1 16.09.2019 18:00
6
Ответы
АнальныйЧервь
07.10.2020 20:14
Var
sum, a,b,c:real;
begin
Readln(a,b,c);
if a > 0 then Write(a, ' ') else sum:= sum + a;
if b > 0 then Write(b, ' ') else sum:= sum + b;
if c > 0 then Write(c, ' ') else sum:= sum + c;
Writeln;
Writeln('Cумма отрицательных эл-в = ', sum);
end.
Пример:
-5 2 1
2 1
Cумма отрицательных эл-в = -5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Vladislav45609
17.12.2019 11:11
Какая сервисная программа используется в целях предотвращения потери данных? проверка дискаактивация виндовсдефрагментацияочистка диска...
Aleks4565
17.12.2019 11:09
Составить программу,которая считает количество вхождений буквы а в заданном тексте.с++...
donga123
29.05.2019 02:40
Что такое свободно-распространяемые программы?...
REIIKA
29.05.2019 02:40
Дайте название последовательностям действий...
pn89290448853
29.05.2019 02:40
На схеме указаны дороги между четырьмя населенными пунктами и отмечены длины этих дорог. длина одной дороги неизвестна. зато известно, что самый короткий путь между...
oli21
29.05.2019 02:40
Написать программу в c++ дан одномерный массив x из n элементов. найти порядковый номер первого по счёту положительного элемента с чётным порядковым номером. все...
sh0d1
15.12.2021 10:12
(Написать решение с ответом) a b c - логические величины a - истина b - истина c - ложь 1) не (a или b) и (c или b) 2) не a или b и c...
pain26
15.12.2021 10:09
Как расширение распознаётся большинством 3D принтера ?...
Pomogatorr
15.12.2021 10:07
Выбери подходящие имена для данного высказывания: (Пол женский)&(В имени 5 букв)V(Пол мужской) ответов несколько Айсу Айнур Акиф Айда...
viktoriapleva
03.10.2019 23:20
Почему в вычислительной технике взята за основу двоичная система счисления?...
Популярные вопросы
Решение примера на дроби: -10 2/7 : 1 13/35 + 3 9/11 : 1 1/55=?...
1
Расчитайте давление на платформе станции метро, находящейся на...
3
)составьте и решите по на тему: сила тяжести....
2
Сделать вывод о доступности запасов пресной воды для человека...
1
№1 назовите части тела лягушки.охарактеризуйте их строение №2...
3
Какой объем водорода выделится при взаимодействии ортофосфорной...
1
Решить графическое уравнение: х2-6х-8=0...
2
Описание короткое день яблока сша 21 октября...
1
1) как князь владимир расширил и укрепил границы государства...
1
Решите уравнение: 5/9 + (х- 2/9 ) = 7/9...
1
sum, a,b,c:real;
begin
Readln(a,b,c);
if a > 0 then Write(a, ' ') else sum:= sum + a;
if b > 0 then Write(b, ' ') else sum:= sum + b;
if c > 0 then Write(c, ' ') else sum:= sum + c;
Writeln;
Writeln('Cумма отрицательных эл-в = ', sum);
end.
Пример:
-5 2 1
2 1
Cумма отрицательных эл-в = -5