Напишите программу : дан массив f, c - целых 30 чисел . найдите произведение положительных и отрицательных чисел.

0909044 0909044    3   27.08.2019 04:30    2

Ответы
elizavetanikan elizavetanikan  05.10.2020 22:08
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(30, -100, 100);
    Println(a);
    Writeln('Произведение положительных ', a.Where(x -> x > 0).Aggregate(1, (x, y)-> x * y));
    Writeln('Произведение отрицательных ', a.Where(x -> x < 0).Aggregate(1, (x, y)-> x * y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика