Напишите программу алгоритмическим языком для нахождения нод по евклиду (делить большое число на меньшее, а потом ему присваивать значение остатка)

sanfirovngmail sanfirovngmail    3   17.07.2019 00:40    3

Ответы
GGG1771 GGG1771  19.08.2020 12:08
Var a,b:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
while (a<>0)and(b<>0) do
  if a>b then a:=a mod b else b:=b mod a;
writeln('НОД=',a+b);
end.

Пример:
a=125
b=50
НОД=25
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика