Напишите программу алгоритм евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на разность большего и меньшего до тех пор, пока одно из них не станет равно нулю; тогда второе и есть нод. напишите программу, которая реализует
этот алгоритм.входные данныевходная строка содержит два числа, разделённые пробелом – a и b .выходные данныепрограмма должна вывести в одной строке два числа: сначала наибольший общий делитель двух введённых чисел, а затем – количество шагов цикла, которые были выполнены.примерывходные данные14
21выходные данные7 3входные данные171 3534выходные данные57 23язык pyton tutor

берсик7 берсик7    3   07.10.2019 14:50    24

Ответы
nosalyaik nosalyaik  10.10.2020 01:48

def gcd(a, b):

   y = 0

   while a != b:

       y += 1

       if a > b:

           a = a - b

       else:

           b = b - a        

   print("%s%s" % (a, y))

string = str(input())

args = string.split(' ')

a, b = int(args[0]), int(args[1])

gcd(a, b)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика