Напишите на паскале программу, которая запрашивает с клавиатуры массив из n чисел, а затем выводит среднее арифметическое всех элементов массива.

Olegbro364682 Olegbro364682    1   23.06.2019 17:50    5

Ответы
Bayleef Bayleef  02.10.2020 09:28
Var n, i, sum: integer;
a: array[1..100] of integer;
average: real;
begin
write('Сколько чисел будет в массиве? ');
readln(n);
sum := 0;
for i := 1 to n do
begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;
average := sum/n;
writeln('Среднее арифметическое: ', average);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика