Напишите мне данное от program до end. (тема "циклы"- pascal abc) написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5, количество суммированных членов ряда задаётся во время работы программы. ниже примерно рекомендуемый вид экрана во время работы программы. вычисление частичной суммы ряда: 1,3,5, введите количество суммированных членов ряда -> 1-5 сумма первых 15 членов ряда равна 330.

nastyagrng nastyagrng    2   06.07.2019 01:20    4

Ответы
Мира1356 Мира1356  29.07.2020 11:53
Program zhn;
var
  i,n,sum:integer;
begin
  writeln('Вчисление суммы членов последовательности: 1,3,5,7...');
  write('Введите количество членов для сложения:');
  readln(n);
  for i:=1 to n*2 do begin
    if i mod 2 <> 0 then sum:=sum+i; //Проверяем что бы число было нечетным
  end;
  writeln('Сумма ',n,' членов прогресии = ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика