Напишите код программы для решения задачи Написать программу, определяющую, к какой весовой
категории относится спортсмен:
до 69 кг — легкий вес;
до 85 кг – средний вес;
до 105 кг – Тяжелый вес;
свыше 105 кг – супертяжелый вес.
Мой ответ​

nikitinallllll nikitinallllll    2   15.03.2021 13:36    5

Ответы
Ксения0112387 Ксения0112387  14.04.2021 13:36

program weight_class;

var x, y:integer;

label 10,20;

 begin

   10:Writeln ('введите вес спорсмена в кг');

   Readln(x);

   if x<69 then

     Writeln('Спортсмен весом ', x, 'кг, относится к легкой категории');

   if (x>=69) and (x<85) then

   Writeln('Спортсмен весом ', x, 'кг, относится к средней категории');

   if (x>=85) and (x<105) then

   Writeln('Спортсмен весом ', x, 'кг, относится к тяжелой категории');

    if x>=105 then

   Writeln('Спортсмен весом ', x, 'кг, относится к супертяжелой категории');

   Writeln(' Будете еще вводить вес спортсмена: 1-Да, другая любая цифра-Нет');

   Readln (y);

   if y=1then

     goto 10;

  end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика