Напишите и ее решение в паскале. массивы составить программу для решения следующей : дан массив целых чисел. выяснить какой элемент массива больше, k-й или p-й.
Var a,b,c:integer; n:array [1..10] of integer; begin writeln('введите номера элементов для сравнения'); readln(a,b); randomize;{скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом} for c:=1 to 10 do begin n[c]:=random(-20,20);{так мы в массив ставим случайное число в диапазоне от -20 до 20} writeln(n[c]); end; if n[a]<n[b] then writeln('меньший элемент массива под номером ' ,a,' больший элемент массива под номером ' ,b) else writeln('меньший элемент массива под номером ' ,b,' больший элемент массива под номером ' ,a); end.
n:array [1..10] of integer;
begin
writeln('введите номера элементов для сравнения');
readln(a,b);
randomize;{скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом}
for c:=1 to 10 do begin
n[c]:=random(-20,20);{так мы в массив ставим случайное число в диапазоне от -20 до 20}
writeln(n[c]);
end;
if n[a]<n[b] then writeln('меньший элемент массива под номером ' ,a,' больший элемент массива под номером ' ,b)
else writeln('меньший элемент массива под номером ' ,b,' больший элемент массива под номером ' ,a);
end.