Напишите эффективную программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество натуральных чисел, кратных числу a, на отрезке [a,b] (включая концы отрезка). программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1≤a≤b≤30000. программа должна вывести одно число: количество натуральных чисел кратных числу a на отрезке [a,b]

roseflover2005 roseflover2005    3   05.06.2019 17:50    4

Ответы
mement0m0ri mement0m0ri  06.07.2020 06:54
Var a,b,i,k:integer;
begin
readln(a);
readln(b);
k:=0;
if (a>b) or (b>30000) or (a<1) then writeln('данные введены некорректно') else begin
for i:=a to b do
if i mod a=0 then k:=k+1;
writeln(k);end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика