Напишите 2 простые программы на C++ 1. Задать одномерный массив целых чисел. И образовать из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа.

2. Генератором случайных чисел задан одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива.

karinapolushin karinapolushin    1   18.11.2020 12:52    12

Ответы
JHope23 JHope23  18.12.2020 12:53

1.

#include <iostream>

#include <vector>

using namespace std;

int main(){

int a,b;

cin>>a;

vector<int> v1;

vector<int> v2;

for(int i=0; i<a; i++){

cin>>b;

if (b%2==0) v1.emplace_back(b);

else v2.emplace_back(b);

}

sort(v1.begin(), v1.end());

sort(v2.begin(), v2.end());

for(auto & i: v1) cout<<i<<" ";

}

2.

#include <iostream>

#include <vector>

using namespace std;

int main(){

vector<float> v;

//здесь нам задают массив

sort(v.begin(), v.end());

cout<<v[0]<<v.back();

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика