tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на с++
Написать программу на с++ даны три стороны одного и три стороны другого треуголь- ника. эти треугольники равновеликие, т.е. имеют равные площади.
ytytuty
1 18.07.2019 21:20
3
Ответы
тагієва
03.10.2020 07:22
#include <iostream>
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
double p = (a + b + c) / 2;
return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main()
{
double a1, b1, c1, a2, b2, c2;
cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
cout << "YES";
else
cout << "NO";
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Лессикаа
07.04.2020 21:25
1. Какая из данных команд увеличивает скорость на 5: 1.Скорость увеличить 5 2.Скорость: скорость + 5 3. Пусть “скорость :скорость + 5 4.Пусть :скорость ”скорость + 5...
89681355832
07.07.2019 15:40
Для долговременного хранения информации служит: а. оперативная память б. процессор в. внешний носитель г. дисковод...
AlifZnanija
23.06.2019 15:40
Кросворди по теме информатика 5 слов...
liz93
01.05.2020 12:29
Паскаль!!Очень надо сдать! ...
РаминаГасымлы
01.05.2020 12:28
Определите значение переменной X после выполнения следующего фрагмента программы: x:=1; repeat x:=x+3; x:=x+1; until x 10; очень...
goodwar40
16.11.2020 06:24
решить задание по информатике! 1. Директор фирмы, которая делает евроремонты в офисах, решил оптимизировать свое предприятие. Он заинтересовался, сколько банок краски...
V1ctoriaF0X
10.09.2019 09:00
Скласти речення про світанок над морем з безособовими дієсловами. (3-4 речення)...
nyurachernikov
10.09.2019 09:00
Могут ли из первых ста членов арифметической прогрессии ровно 42 быть целыми числами? thanks...
mulz
10.09.2019 09:00
Іть перевести числовий масштаб в іменований 1: 10000.будь вчитель дуже !...
asarapik
10.09.2019 09:00
Соотнеси полные имена и их сокращенные варианты: 1) larry а) carolyn 2) lou б) abigail 3) lynn в) adeline 4) aline г) louis 5) abby д) laurence а) 1г, 2д, 3а, 4в, 5бб)...
Популярные вопросы
В треугольнике ABC даны две стороны BC=3,AC=3√2 и угол A равный 45°....
3
мне класс произведение белая радуга...
2
с математикой Найти значение функций в точке х0 = - 1, если f (x)...
3
Как долго длилась война? Кто был вовлечен в войну? Куда отправились...
1
Сөздіктен кестедегі сөздердің мағынасын анықта. Сөздерді сөз таптарына...
3
На рисунке отрезки KM и LN пересекаются докажи что прямые KL и MN...
1
Заполните таблицу тематическими сведениями ...
1
В цистерне машины для полива улиц находится вода. на сколько? если...
2
Изобрази одну модель процесса в неживой природе. Составь краткую характеристику...
1
At pH=5, insulin remains at the start during electrophoresis. What...
3
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
double p = (a + b + c) / 2;
return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main()
{
double a1, b1, c1, a2, b2, c2;
cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
cout << "YES";
else
cout << "NO";
}