tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать в паскаль. вводится предложение.
Написать в паскаль. вводится предложение. определить длину самого длинного слова.
Lala0911
3 06.06.2019 11:20
2
Ответы
Ангелина111011
06.07.2020 16:23
Var s:string;
m,tmp,i:integer;
begin
readln(s);
for i:=1 to length(s) do begin
if (s[i]<>' ') then inc(tmp)
else begin
if tmp>m then m:=tmp;
tmp:=0;
end;
end;
if tmp>m then m:=tmp;
writeln(m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
anechkasun1
27.11.2020 09:23
Сделать 17 таблиц по примеру...
Божа
27.11.2020 09:22
Сделать конспект на тему форматирование элементов электронных таблиц...
IrinaKorolevskih
29.01.2021 23:38
впорядкований набір деякого типу називають- зарание...
elizavetava
29.01.2021 23:45
Ребят Как сделать в C# if (переменная == текст || text )Мне нужно там где в переменной done было два ответа пользователя записано в коде это у меня так:...
Soos11111
20.01.2021 19:02
Питон Напишите программу, которая создает массив А со значениями: 1, 4, 9, 16, ...121 Для вывода используйте команду печати массива print(A)...
гол38
16.12.2020 09:23
Тестовый файл состоит не более чем из 106 символов А В и С . Определите количество идущийх подрят символов С....
Король234
16.12.2020 09:24
при интернет соединении с максимальной скоростью передачи данных 10 мбит/с, Сколько времени будет передвигаться файл размером 3 Гбайт...
Kxmm
16.12.2020 09:24
Составить программу получения слова «правило» из слова «управление», используя процедуры Delete и...
nikiton22877
16.12.2020 09:26
Найдите информационный объем который несёт в себе ваши фио Курманбекова Бегимай...
akrontsova
16.12.2020 09:28
Даны натуральные числа от 17 до 36. Вывести на консоль те из них, которые при делении на 3 дают остаток. C++...
Популярные вопросы
Какое проверочное слово к слову новшество?...
2
Надо словосочетание со словом общество...
2
Автомобиль проехал расстояние между двумя со скоростью 60 км/ч и вовзратился...
1
:1.йогурт стоит 7 рублей 20 копеек. какое наибольшее число йогуртов...
2
Разделить на слоги: алфавит,апрель,береза,быстро,вдруг,весело, ветер,воробей,ворона,город,девочка,дежурный,декабрь,деревня,дорога,до...
2
Основания прямоугольной трапеции равны 4 см и 7см, угол 60 градусов....
1
Поставить предложения сначала в презенс(präsens),а потом протеритум(präteritum)....
1
Составе словосочетания со словами: телемост, аэробус, телезвезда, геймер,...
1
Рабочий за восьмичасовой рабочий день вытачивает 80 деталей ,а его ученик...
3
Угол аов=50º,foe=70º найдите углы aoc bod coe cod...
3
m,tmp,i:integer;
begin
readln(s);
for i:=1 to length(s) do begin
if (s[i]<>' ') then inc(tmp)
else begin
if tmp>m then m:=tmp;
tmp:=0;
end;
end;
if tmp>m then m:=tmp;
writeln(m);
end.