Написать программы на Pascal. 1. Написать программу, которая по двум катетам считает площадь прямоугольного треугольника.
2. Написать программу, которая по возрасту человека может определить - совершеннолетний ли он.
3. Написать программу, которая считает кол-во цифр в числе.

санялещидзе санялещидзе    3   27.10.2021 09:22    3

Ответы
МамаВера1 МамаВера1  27.10.2021 09:30

1) var

a, b, c, S, P : real;

begin

write('Введите катет a : ');readln(a);

write('Введите катет b : ');readln(b);

c := sqrt(sqr(a)+sqr(b));

P := a + b + c;

S := (a*b)/2;

writeln('Периметр равен : ', P);

writeln('Площадь равна : ', S);

readln;

end.

2) program choice_2;

uses crt;

var year: integer;

begin

clrscr;

write(‘Ваш возраст > ‘); readln(year);

if (year > 0) and (year < 18) then

write(‘Вы не достигли совершеннолетия’)

else if (year > 17) and (year < 150) then

write(‘Вы достигли совершеннолетия’)

else write(‘Вероятно, введены неверные данные’);

readkey;

end.

3) uses crt;

Var n,m,p,k:integer;

Begin

write('n=');read(n);

m:=n;k:=0;

while m<>0 do begin

p:=m mod 10;

K:=K+1;

m:=m div 10;

end;

writeln('k=',k);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика