Написать программы.. 1 напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры 2 напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран 3 напишите программу которая при вводе пяти чисел вычисляла бы их сумму и произведение, и выводила на экран, что из этого больше.

ddfgdfgdfg ddfgdfgdfg    1   30.08.2019 21:30    2

Ответы
sashok0031 sashok0031  06.10.2020 05:46
1)
Var x: real;
Begin
writeln ('Введите число');
readln (x);
if x>0 then
writeln ('Число ', x, ' положительное')
else
if x<0 then
writeln ('Число ', x, ' отрицательное')
else
if x=0 then
writeln ('Число ', x, ' не является ни положительным, ни отрицательным');
End.

2.
Var x, y: real;
Begin
writeln ('Введите два числа');
readln (x,y);
if x>y then writeln (x)
else
if x<y then writeln (y)
else
if x=y then writeln ('Числа равны');
End.

3.
Var x, sum, pr: real;
i: integer;
Begin
sum:=0;
pr:=1;
For i:=1 to 5 do
begin
write ('Введите число: ');
readln (x);
sum:=sum+x;
pr:=pr*x;
end;
writeln ('Сумма чисел = ', sum);
writeln ('Произведение чисел = ', pr);
if sum>pr then writeln (sum)
else
if sum<pr then writeln (pr)
else
if sum=pr then writeln ('Сумма и произведение равны');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика