Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. окончание ввода – число 0. протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. паскаль

supanzerbe supanzerbe    1   21.05.2019 14:10    16

Ответы
тупой172 тупой172  15.06.2020 23:46


uses crt;
var x,min,max:integer;
begin
clrscr; min:=0;max:=0;
Writeln('Write x = ');
readln(x);
min:=x;
max:=x;
while x<>0 do
begin
readln(x);
if ((min > x) and (x<>0)) then min:=x;
if ((max < x) and (x<>0)) then max:=x;
end;
writeln('max = ',max);
writeln('min = ',min);
readln
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика