Написать программу! ! while и repeat 1)напечатать все отрицательные числа из диапазона от а до б, с шагом h. 2)напишите программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

plagods plagods    2   02.06.2019 04:30    5

Ответы
Nastyamil681 Nastyamil681  01.10.2020 16:56
1.program z;
var a,b,c:integer;
begin
read(a,b,c);
while (a<b) and (a<0) do
begin
write(a:4);
a:=a+c;
end;
end.
2.program z;
var a,b,c:integer;
begin
read(a,b,c);
repeat
write(a:4);
a:=a+c;
until (a>b) or (a>-1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика