Написать программу, вычисляющую и сохраняющую в одномерном массиве значение функции у={x при х≤0, х² при х> 5,4 если иначе. на интервале [-10; 10] с шагом 0,5. на паскале или си/си++ заранее

Фидан77714 Фидан77714    3   29.06.2019 11:50    7

Ответы
DaryaAminina DaryaAminina  23.07.2020 12:49
{41 = (20/0.5+1}}
var a:array [1..41] of real;
    h,y,x:real;
    i:integer;
begin
 x:=-10.5;
 h:=0.5;
 i:=0;
 repeat
  i:=i+1;
   y:=4;
   if x<=0 then y:=x
     else if x>5 then y:=x*x;
     a[i]:=y;
   x:=x+h;
  writeln(x:8:2,a[i]:8:2);
 until x>=10;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика