Написать программу: вычислить количество точек с целочисленными координатами, в круг с радиусом r и с центром в начале координаты ур: x*x+y*y= r*r

крутелик9 крутелик9    1   20.07.2019 22:30    2

Ответы
Карамелла Карамелла  22.09.2020 23:47
Var i,j,n,k: integer;    r: real;begin  write('радиус:  ');  readln(r);  n:=trunc(r);  k:=0;  for i:=-n to n do  for j:=-n to n do  if sqr(i)+sqr(j)<=sqr(r) then k:=k+1;  writeln('число точек в круге:  ',k);end.    
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика