tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу вычисления
Написать программу вычисления выражения (5а-3)(4-3b)+c
в паскале
andriYThack
1 25.11.2019 23:22
0
Ответы
anasolosina256
10.10.2020 15:57
Var a, b, c: integer;
begin
readln (a, b, c);
writeln ((5*a-3) * (4-3*b) + c);
end.
Поясняю за код:
Первой строкой задаём переменные (аbc) и обозначаем их тип (здесь: integer - целые числа, при необходимости - замени на числа с плавающей точкой);
Второя строчка - для красоты, необязательна;
Третья - начало программы;
Четвертая - считывает с клавиатуры переменные аbc;
Пятая - выводим на экран результат выражения,
Шестая строка - конец.
---Так же можно было задать новую переменную d (что бессмысленно, но, наверное, пока именно этот вариант тебе подойдёт)
var a, b, c, d: integer;
begin
readln (a, b, c);
d:=((5*a-3) * (4-3*b) + c);
writeln(d)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Minecraftserver34
13.04.2020 18:27
Оформить задачу: ”Расчет оптимальных параметров геометрической фигуры” в редакторе WORD...
karicristle313
25.05.2020 20:23
На жестком диске C: в каталоге Robot хранится документ resumeis.doc . Каков полный путь к файлу? a. Robot\resumeis.doc; b. c:\...\resumeis.doc; c. c:\Robot\resumeis.doc....
DiaGirlNya
25.05.2020 20:23
Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(1) = 5 F(n) = F(n–1) * (n-1), при n 1....
Стешулький361953
25.05.2020 20:24
Надати змінній а значення 2;повторити 4 рази: розвязати рівняння ах+5-24;збільшити значення а на 3 я третий раз задаю этот во оформить это,лол здесь люди есть вообще??...
Sonni18
16.03.2019 16:30
По информатике: знаменатель на 2 раза больше числителя, если числитель увеличить в 5 раз, а к знаменателю прибавить 5 и сократить полученную дробь, то получится 3...
ZzzGoshAzzZ
17.04.2020 15:49
таблицу ексель. Даю 100(у вас скорее будет написано 50) (1-5задание)...
bagfaver
17.04.2020 15:52
Запиши программу на языке Паскаль для: y = {0, если x ≤ 0 {x, если 0 x ≤ 1 {x², если x 1 (y:3:0) Запусти программу и введи значение x=20....
Natali20171
17.04.2020 15:52
На станции находится состав с n различными грузами, веса которых равны соответственно с1, с2, … сn. Определить, какое максимальное количество грузов можно поместить...
envoyfromhell
06.07.2019 10:30
80 ! ! нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом...
green121
06.07.2019 10:30
Запиши слова в три столбика: слова из одного слога,из двух слогов,из трёх слогов.напиши в каждый столбик ещё одно слово. класс,друг,дружба,подруга,лисица,ёжик,осина,дерево,лист,листик,аист,клей....
Популярные вопросы
Дайте развёрнутый ответ на вопрос. Объем письменной работы - 110-130...
1
Read the text. My town My town is very big and beautiful. The...
3
Рассказ о любом изобретении творческое задание когда этим был...
2
Если изображение попадает на ,то мы лучше всего видим изображение...
1
C) x квадрат + 2xy + y квадрат+ 2x +2y + 1...
1
Как называется слово, которым можно обозначить любой из однородных...
3
)Заполни таблицу, выписав из текста слова-действия (глаголы) клёна...
1
Докажите, что когда все двугранные углы при ребрах основания пирамиды...
3
Продукция отрасли машиностроения по производству промышленного...
1
1.В прямоугольном треугольнике катеты а и Б равны, гипотенуза...
1
begin
readln (a, b, c);
writeln ((5*a-3) * (4-3*b) + c);
end.
Поясняю за код:
Первой строкой задаём переменные (аbc) и обозначаем их тип (здесь: integer - целые числа, при необходимости - замени на числа с плавающей точкой);
Второя строчка - для красоты, необязательна;
Третья - начало программы;
Четвертая - считывает с клавиатуры переменные аbc;
Пятая - выводим на экран результат выражения,
Шестая строка - конец.
---Так же можно было задать новую переменную d (что бессмысленно, но, наверное, пока именно этот вариант тебе подойдёт)
var a, b, c, d: integer;
begin
readln (a, b, c);
d:=((5*a-3) * (4-3*b) + c);
writeln(d)
end.