tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
80 ! ! нужно составить программу
80 ! ! нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом
envoyfromhell
2 06.07.2019 10:30
3
Ответы
vldslvkonnov089
29.07.2020 16:47
Program zhn;
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
незнаю178
27.08.2019 03:40
Сообщение нумерация страниц калан титулы по информатике...
M10041999
03.02.2022 11:00
Cтрока текстового файла Numbers.txt представляет собой строку, состоящую из цифр от “0” до “9”. Напишите программу, заменяющую четыре цифры в этом файле символом ‘/’, начиная с позиции...
pspoff
03.02.2022 10:58
мне нужен разбор 6 заданий по операционным системам! Запишите ответы с 4 по 9 задания....
diana20102007
03.02.2022 10:53
3. Складіть проект з використанням змінних для малювання 2-х квадратів, лініями різної товщини і різного кольору. Довжини сторін у квадратів різні і вводяться з клавіатури. Проєкт...
Neon1407
03.02.2022 10:53
История и перспективы робототехники Установи соответствие между названием робота, представленного на Всемирной конференции по робототехнике в августе 2019 года в Пекине, и его назначением....
standartny1ychenik
03.02.2022 10:50
III Программирование линейных алгоритмов. Урок 2 Выбери фигуру, для которой найдена длина ее контура. L1=2*pi*r L2=L1/4 3=L1-L2+2*r Рис. 1 Рис...
olesahshhahas
03.02.2022 10:48
. Python. Определите среднее значение всех элементов последовательности, завершающейся числом О. Сам ноль в последовательность не входит, а служит как признак её окончания....
alya5511Аля
20.10.2020 07:11
Сложить в двоичной системе:1) 525+3252) 660+2913) 299+301...
Валерия1804
20.10.2020 07:11
1)Запишите константу в форме с фиксированной запятой: A= 0,5E-4 2)Запишиеь числовую константу А в форме с плавующей запятой: А=16000 ПОЖАЙЛУСТА!...
Makarzzz
20.10.2020 07:13
кто разбирается в сделать задание ( )...
Популярные вопросы
Учебник 4 класса нагибина 2 часть с 99-106 вопросы 2,3,4...
1
Надо 35 напишите формулы 51. йодид натрия 52. карбонат бария 53. сульфат калия...
3
Почему памятник затопленным кораблям можно считать символом крымской войны? (1853-1856)...
2
Іть будь-ласка. з слова ввести в речення синтаксичний розбір: козінаки, капучина,...
1
Двузначное число оканчивается цифрой 3. если сумму его цифр умножить на 4, то получится...
3
Розказати як на мене впливає музика яку я слухаю...
1
Сторона квадрата 24см. найди периметр и площадь....
1
Название моста, где иван - крестьянский сын сразился с чудом-юдом....
1
Вслове на месте нужно писать в окончания букву е потому что завтра в школу надо...
3
Кратко описать город новгород в древней руси...
1
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.