tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу вычисления
Написать программу вычисления а10, где а - данное число если получившаяся программа требует более четырех умножений (использование функции sqr тоже считается умножением), то дать более экономное решение.
egorikguru
2 21.09.2019 12:10
5
Ответы
Аня79780607646
08.10.2020 07:07
Var a,a2,a4,a8,a10:integer;
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.
Пример:
2
1024
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ermekbaevadinara
21.08.2019 19:40
Вследующих высказываниях выделите простые высказывания, обозначив каждое из них буквой; запишите с букв и логических операций данное высказываение : на уроке восьмиклассники...
Красотка12092002
21.08.2019 19:40
Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 0 до 1....
arzushka75
12.12.2020 08:15
2. Для хранения целого отрицательного числа используется 1 байт памяти. Определите диапазон чисел, которые могут храниться в памяти. Запишите внутреннее представление числа:...
Pollymironova
12.12.2020 08:15
1. Из чего состоит Растровая графика?1.Линии2.Пикселей3.Многоугольников...
svettapan
12.12.2020 08:15
Служебное слово для подключение модуля стандартных функций def export import Standart...
stasymitaki
12.12.2020 08:14
30 ячеек электронной таблицы содержится в диапазоне:а) E2:G11б)A15:D20в)C4:F9...
muradir1102
12.12.2020 08:14
Какой результат будет получен в ячейке с формулой? ...
svensyea
12.12.2020 08:14
Доклад на тему первый компьютер написать только самое важное и главное не могу найти...
Няшка1097
04.10.2019 00:01
Постройте таблицы истинности для следующих логических выражений: a) ¬a˄b˅c б) ¬a˅(¬b˄c)...
gjhjcznrj
04.10.2019 00:01
Даны 2 целых числа а и b узнать делится ли число а на b или b на а; если делится то вывести ответ на экран,если нет то вывести сумму этих чисел. )...
Популярные вопросы
Окружний прокурор звернувся з протестом на дії міського голови, який своїм...
1
Знайдіть площу прямокутника , довжина якого доривнюе 8 см , а ширина - 4см...
3
Через провідник протягом 25 хв тече струм 5 А, і при цьому виділяється кількість...
3
До іть будь ласка 6 питання і 7 ( на фото)...
2
2. ответьте на вопрос: Каким образом интернет экономит наше время? (Приведите...
2
При равномерном перемещении груза массой 400г по наклонной плоскости динамометр...
1
Card 3 1. Do you lead a fast lifestyle? Explain. 2. Can you think of three...
1
Найти медиану числового ряда: 85;64;76;45;92;86;94;81....
1
Щоб знайти масу розчиненої речовини у розчині необхідно:??...
3
Електрична піч споживає потужність 8 кВт живиться від мережі 220 В. Визначте...
3
begin
readln(a);
a2:=a*a; // a^2
a4:=a2*a2; // a^4
a8:=a4*a4; // a^8
a10:=a8*a2; // a^10
writeln(a10);
end.
Пример:
2
1024