Написать программу вводит две стороны прямоугольника (целые числа). определить радиус окружности (с точностью до четырех знаков после запятой), описать около него и его периметр. сколько окружностей можно нанизать на нитку, с длинной, ровной периметру прямоугольника.

Shamsudi95 Shamsudi95    3   03.08.2019 01:50    1

Ответы
SHiiimochka SHiiimochka  30.09.2020 05:09
Из условий я не понял про нанизывание на нитку окружностей. Остальное сделал на языке Паскаль. На своём компьютере не проверял, т.к. данный язык у меня не установлен. На фото я укзал рисунок моего понимания условий задачи.
- - - - - - - - - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
var
     a,b : integer; {описываем длины сторон}
     r,p : real; {описываем радиус и периметр}
begin
   write ('Введите длину первой стороны прямоугольника: ');
   readln(a);
   write ('Введите длину второй стороны прямоугольника: ');
   readln(b);
   r:=(sqrt(a*a+b*b))/2; {находим радиус}
   r:=trunc(r*10000)/10000; {округляем до четырёх знаков после запятой}
   p:=(a+b)*2; {находим периметр прямоугольника};
   writeln('Радиус окружности равен: ',r);
   writeln('Периметр прямоугольника равен: ',p);
end.

Написать программу вводит две стороны прямоугольника (целые числа). определить радиус окружности (с
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика