написать программу в питоне (Нужно чтобы получилось как в примере)


написать программу в питоне (Нужно чтобы получилось как в примере)

PolinaMm PolinaMm    2   26.11.2021 10:51    5

Ответы
alikber2004 alikber2004  01.01.2022 11:51

even, odd = 0, 0

x = int(input("Введите число: \n"))

while x > 0:

   if (x % 10) % 2 == 0:

       even += 1

   else:

       odd += 1

   x //= 10

print(f"Количество чётных цифр {even}")

print(f"Количество нечётных цифр {odd}")        

ПОКАЗАТЬ ОТВЕТЫ
niavente niavente  01.01.2022 11:51

Python:

number = input("Введите число: \n")

even = len([i for i in number if int(i) % 2 == 0])

odd = len(number) - even

print(f"Количество чётных цифр {even}")

print(f"Количество нечётных цифр {odd}")

ПОКАЗАТЬ ОТВЕТЫ