Написать программу в паскале.заполнить массив случайными величинами от -100 до 100.найти сумму элементоав массива.

Vanilingus Vanilingus    3   12.09.2019 15:30    3

Ответы
madina2421 madina2421  07.10.2020 09:55
Const n=10;
var a:array[1..n] of integer;
i,s:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(201)-100;
 write(a[i]:4);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('s = ',s);
end.

Пример:
Массив A:
71 -39 57 33 52 -96 77 -79 -71 -79
s = -74
ПОКАЗАТЬ ОТВЕТЫ
qaz160904 qaz160904  07.10.2020 09:55
//PascalABC.NET
//Версия 3.3. сборка 1583 (25.11.2017)

begin
 var a:array[1..100] of integer;
 var n,s:integer;
  write('Введите размер массива: ');readln(n);
  for var i:=1 to n do 
  begin
   a[i]:=random(-100,100);
   write(a[i],' ');
   s:=s+a[i];
  end;
  writeln;
  writeln('Сумма: ',s);
 readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика