Написать программу в паскале. входные данные : вводятся 4 числа, а, b, c, d выходные данные : найдите все целые решения уравнения ax^3+bx^2+cx+d=0 на отрезке [0,1000] и выведите их в порядке возрастания. если на данном отрезке нет ни одного решения, то ничего выводить не нужно.
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var (a,b):=ReadInteger2('Введите a,b,c,d->');
var (c,d):=ReadInteger2;
Write('Корни: ');
for var x:=0 to 1000 do
if a*x**3+b*x**2+c*x+d=0 then Write(x,' ');
end.
Пример:
Введите a,b,c,d-> 1 -3 -13 15
Корни: 1 5