Написать программу в паскале определяющую и выводящую наибольшее из трех чисел

manilowyn2 manilowyn2    2   18.05.2019 06:30    1

Ответы
ANONIM235063 ANONIM235063  11.06.2020 12:50

Program MAXOF3;

 

Var a,b,c,t,max: Real;

 

Begin

    Writeln('Type 3 different numbers');

    Write('a = '); Read(a);

    Write('b = '); Read(b);

    Write('c = '); Read(c);

    t := (a+b)/2 + abs(a-b)/2; {abs(x) - модуль числа х}

    max := (t+c)/2 + abs(t-c)/2;

    Writeln('max = ', max:2); {:2 - количество знаков после запятой}

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика