Написать программу в паскале. найти наибольший общий делитель 2 натуральных чисел!

lerahmru lerahmru    1   17.05.2019 17:10    1

Ответы
illia2006 illia2006  10.06.2020 22:17

program prim; uses crt; var x,y:integer; begin writeln ('введите x,y'); readln (x,y); while x<>y do begin if x>y then x:=x-y else y:=y-x end; write ('НОД=',x); end.

ПОКАЗАТЬ ОТВЕТЫ
Vftfg Vftfg  10.06.2020 22:17

var a,c,b:integer;
begin
readln(a,b);
while b>0 do begin
a:=a mod b;
c:=a;a:=b;b:=c;
end;
writeln(a);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика