Написать программу в паскале которая вставит между буквами введенного слова пробел

Dashylka8 Dashylka8    1   18.05.2019 13:40    3

Ответы
sonya410 sonya410  11.06.2020 20:14

var
    s, s_new: string;
    i: integer;

begin
    read(s);
    for i := 1 to length(s) do
        s_new := s_new + s[i] + ' ';
    writeln(s_new);
end.

ПОКАЗАТЬ ОТВЕТЫ
Тосямдр Тосямдр  11.06.2020 20:14

 Program BlankWord;

Uses Crt;

var s1:string;

        l:integer;

begin

     clrscr;

     write('Введите Слово:');

     readln(s1);

     l=length(s1);

 

     for i:=l downto 1 do
         if(i mod 2 = 0)then
              Insert(' ', s1, i);
              writeln(s1);
              readkey;

     

 end.

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика