Написать программу в паскале, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением.

madoleh madoleh    2   17.05.2019 14:40    1

Ответы
лунный3 лунный3  10.06.2020 19:17

var a:array [1..100] of integer;

n,i,j:integer;

f:boolean;

BEGIN

  read(n);

  f:=false;

  for i := 1 to n do begin

    readln(a[i]);

    for j:= 1 to i-1 do

      f=f or (a[i]=a[j]);

  end;

  writeln(f);

 

END.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика