Написать программу в паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.

pups223 pups223    1   24.08.2019 11:50    2

Ответы
rot3 rot3  05.10.2020 16:38
Program n1;
var a,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
max:=0;
while not eof(f) do
begin
read(f,a);
if (abs(a)>max) and (a<0) and (a mod 2 <>0) then max:=a;
end;
close(f);
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика