Написать программу в паскале: даны две строки: s1 и s2. можно ли из символов строки s1 составить строку s2? регистр значения не имеет. (например a) s1=’april’, s2=’may’. ответ: false b) s1=’rom’, s2=’room’. ответ: false, т.к. буква ‘o’ встречается в строке s1 один раз. c) s1=’tomorrow’, s2=’motor’. ответ: true)

mashatemni mashatemni    2   07.06.2019 08:20    13

Ответы
Ксения200612 Ксения200612  07.07.2020 06:52
Var
  i,n:integer;
  s1,s2:string;
  f:boolean;
begin
f:=true;
writeln('Введите первую строку');
readln(s1);
writeln('Введите вторую строку');
readln(s2);
s1:=LowerCase(s1);
s2:=LowerCase(s2);
i:=1;
repeat
  n:=pos(s2[i],s1);
  if n>0 then delete(s1,n,1) else f:=false;
  i:=i+1;
  until i=length(s2);
writeln(f)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика