Написать программу в паскале: дано натуральное число n. заменить порядок следования цифр числа n на обратный.

April3369 April3369    1   04.06.2019 15:10    5

Ответы
уеее1 уеее1  05.07.2020 14:15
Var
  n,x:string;
  i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.

или можно так:

var
  n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
ПОКАЗАТЬ ОТВЕТЫ
Kruglivnik1ta Kruglivnik1ta  05.07.2020 14:15
Var a, N: integer;
begin 
    writeln('Введите число'); 
    readln(N); a:=0; 
    while N>0 do begin 
        a:=a*10+N mod 10;  
        N:=N div 10; 
      end; 
   writeln (a); 
   readln; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика